Issue with upstream provider

Incident Report for Shiplify

Resolved

AWS has reported implementing a fix, and we have seen affected services recover. We are working through the backlog of jobs, but things appear to be coming back online.
Posted Oct 20, 2025 - 05:43 EDT

Identified

We are experiencing issues with an upstream provider (Amazon Web Services). Many services are up but some are delayed. We will post updates here as we have them.
Posted Oct 20, 2025 - 05:33 EDT
This incident affected: Shipment Batch Processing.