Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 07, 2024 - 08:00 EDT
Scheduled
We will be undergoing scheduled maintenance to install new rules to our firewall systems. We do not expect any impact to system availability during or after this maintenance. However, should you experience any issues contacting the website or API please contact support as normal.
Posted Jul 17, 2024 - 10:15 EDT
This scheduled maintenance affected: Carrier Portal and Shipment Billing API.