Upstream components degraded

Incident Report for Shiplify

Resolved

The upstream providers have repaired their services and we are no longer seeing slow or degraded performance.
Posted Jun 12, 2025 - 15:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 15:06 EDT

Investigating

We are still online, however services that Shiplify uses to provide our technologies to you, are currently experiencing issues. For example Cloudflare which provides WAF and DNS to Shiplify is experiencing widespread outages. This in turn is causing slow response times in Shiplify's systems. We are closely monitoring their status, and will update as they effect repairs and we know more.
Posted Jun 12, 2025 - 15:05 EDT
This incident affected: Carrier Portal, Shipment Batch Processing, and Shipment Billing API.